Nuxt build exportOnlyLocals invalid option

2021. 4. 6. 00:40Trouble Shooting

728x90

nuxt extractcss ignoreorder PostCSS Loader has been initialized using an options object that does not match the API schema

 

nuxt에서 extractcss 관련한 오류가 발생하였는데, vuetify에서 생긴 문제로 보입니다.

 

많은 자료 조사 결과 다양한 해결책을 제시했는데

  • extractCss: true를 ignororder를 추가 (이미 설정됨)
  • node-sass를 설치 (안됨)
  • sass-loader를 설치 (안됨)
  • sass를 설치 (이미 설치됨)
  • 위 패키지들을 특정 종속성으로 맞추어줌 (안됨)
  • nuxt 2.15.3으로 강제 설치 (콘솔로그는 사라졌으나 웹상에서는 여전히 오류 발생)
  • postcss-loader를 설치 (안됨)
  • postcss-loader 관련 webpack 설정 추가 (안됨)
  • build 옵션 모두 비활성화 (안됨)
  • node_modules, package-lock.json 제거후 재설치 (안됨)

더많은걸 해보았지만 대략 다 비슷한 해결방안이었습니다.

저의 경우는 

 

github.com/webpack-contrib/sass-loader/issues/530#issuecomment-688770088

 

ERROR in ./node_modules/css-loader!./node_modules/sass-loader/lib/loader.js!./node_modules/extract-text-webpack-plugin/dist/load

My code works perfectly in dev environment when I try npm run build I get the following error: ERROR in ./node_modules/css-loader!./node_modules/sass-loader/lib/loader.js!./node_modules/extract-tex...

github.com

postcss-loader 버전을 3.0.0으로 설치하고 css-loader를 최신으로 설치하여 해결하였습니다.

728x90
1 2 3 4 5 6 7 ··· 56